• Dear forum reader,
    To actively participate in our forum discussions or to start your own threads, in addition to your game account you need a forum account. You can
    REGISTER HERE!
    Please ensure a translation in to English is provided if your post is not in English and to respect your fellow players when posting.
  • Halloween Event 2021


    Read all about the Halloween Event 2021 here!
  • Castle System

    The Castle System is a brand new feature in Forge of Empires which aims to reward players that are playing Forge of Empires actively. Come check it out in your city!
    Do you want to know more about this new feature? Then click here!
  • Cultural Settlement - Mughal Empire

    We are proud to present you our brand new Cultural Settlement: The Mughal Empire!
    This is the fifth of our Cultural Settlements, and your job is to help expand the Mughal Embassy.
    Read all about it here!

Feedback Daily Changelog w/c 26th April

podkap1970

Emperor
anyone else have problems with loading their city?, since today afternoon, its more or less unplayable for me, with Firefox/MS Edge
my city takes around 4 min to load, and it does not fully load, even after cleared cache/cookies/cake and restarted PC twice, nothing do help
 

lordwasa

Community Manager
anyone else have problems with loading their city?, since today afternoon, its more or less unplayable for me, with Firefox/MS Edge
my city takes around 4 min to load, and it does not fully load, even after cleared cache/cookies/cake and restarted PC twice, nothing do help
Hi there,
Are you still experiencing this issue?
 

podkap1970

Emperor
Hi there,
Are you still experiencing this issue?
yes, i'm out of solutions, an expedition fight takes 2+ min until it pops up until i get the result
when i click the GBG building to get into GBG, i get loading screen, nothing happens after 10 min, i have to reload cty, which takes another 2-3 min, without grass? (screenshot)
Screenshot_6.jpg
oh grass came back, but, well its green at least now ;)
Screenshot_7.jpg

i just have problems to load all textures i think, or it takes forever to load

maybe tomorrow its fixed (which often happens), i have often this long loading times in the afternoon (server time)


Edit: after another try to get into GBG, it did load after 2 min, after i get back to city, grass is blank again in my city ;)
i think after more and more tries to get into something it loads more and more textures


Edit 2: i have no problem to play other games (STO/The Division 2), i also installed newest videocard drivers (uninstalled with DDU first ;) )

Edit 3: after 5 more min, my city did fully load, with all textures
 
Last edited:

podkap1970

Emperor
new day, same problem, in the afternoon, it takes very long until i can do any activity in my city, because it does not load the stuff, if its GBG or GE or my city, or PvP Arena, anything, in the morning there was no problem