• Dear forum reader,
    To actively participate in our forum discussions or to start your own threads, in addition to your game account you need a forum account. You can
    Please ensure a translation in to English is provided if your post is not in English and to respect your fellow players when posting.

Contact Support: Continent map causes crash


tried 3 or 4 browsers, 3 worlds, cleared cache, etc
When I sit on the continent map, probably only when an active scout is in progress, the game always crashes, i.e. looks like the java crashes we used to have even though I know it's not Java anymore. screen goes blank with a very tiny x in the upper left corner.
It used to be a minor annoyance, just open the province quickly enough and I could avoid the crash but now that I entered SAM and have to do the exploration sites, it takes me 3 tries before I can complete a fight and still most of the time don't see the rewarded Mars Ore before it crashes.
These crashes happen on ZZ-1, US-7 and US-27 using Chrome, Opera, Edge or Firefox.
Browser or App
Browser or App version and version number
Chrome Version 102.0.5005.63 (Official Build) (64-bit)
Opera Version:87.0.4390.45
Microsoft Edge Version 101.0.1210.39 (Official build) (64-bit)
FireFox 101.0 (64-bit)
Recreation steps
Open continent map, probably only when an active scout is in progress, and sit and wait
was minor but now that I am in the space ages and have the exploration sites it's very annoying
Can this be reproduced?

Velvet Thunder

Beta Moderator
Unfortunately we have not been able to reproduce this. If you are still encountering it please let us know.


I have collected some more info, I think you're right that a support ticket would be best but for search purposes I'll post here also.

I have a MS Surface Pro with a very high native resolution of 2736x1824 and a recommended scaling of 200%, which I have been running at 150%. Having the game open, even without doing anything and all animations off, would already cause my GPU to run at 90%-100%. Obviously lag was always atrocious.

I've now changed the resolution to 1920x1200 with a scaling of 100% and GPU usage has dropped to 30%-40% and the crashes are history. Although this solves the issues with the game, it's not a solution to eliminate all capabilities of my laptop just to be able to run a game.


I can relate to this. It happened the other day where I got a "ghosted" game. Half of the elements (layers) were loaded while others did not. The roads in settlements weren't showing up (invisible) that it made it hard to reconstruct my settlement by moving around. Thought it was my system and went to clear cache as a result. It somewhat worked but it is present from time to time.

Perhaps the development team need to check on their layering/elements as it may have something to do with the current one (the one with the disappearing timers off certain buildings).