• Dear forum reader,
    To actively participate in our forum discussions or to start your own threads, in addition to your game account you need a forum account. You can
    REGISTER HERE!
    Please ensure a translation in to English is provided if your post is not in English and to respect your fellow players when posting.
  • Halloween Event 2021


    Read all about the Halloween Event 2021 here!
  • Castle System

    The Castle System is a brand new feature in Forge of Empires which aims to reward players that are playing Forge of Empires actively. Come check it out in your city!
    Do you want to know more about this new feature? Then click here!
  • Cultural Settlement - Mughal Empire

    We are proud to present you our brand new Cultural Settlement: The Mughal Empire!
    This is the fifth of our Cultural Settlements, and your job is to help expand the Mughal Embassy.
    Read all about it here!

Login Problems on 24-Jan-2014

DeletedUser2752

What happens when you try to log in? Does it just redirect you back to the page that you show?
 

DeletedUser4628

The browser is not the problem, I still can play on my other worlds, only the beta session crashed.
Someone of the support must end my session, so that I can relogin......
 

DeletedUser1036

Can I get an update? Are you still experiencing these problems? I know it may work on different servers, but that does not mean it is not your browser. Cookies get corrupted, other things along those lines. Try clearing cache, and cookies, see if that helps. If not, let me know.
 

DeletedUser1036

This was a new issue, which has since been fixed, let me know if anyone else is still having issues, :(

Lol
 

Andi47

Overlord
At the moment I can't login - retrying I come either to the maintenance message (since MUCH more than the 10 minutes announced there, it's rather one hour now, what's going on?), to the loading page (getting stuck at ~55%), an error message in the browser and to the starting page saying either "login not possible, try again later" or "error 405 - not allowed". (I have seen all of them during the last hour)

Edit: I should not set my supply buildings for 1-hour productions. I keep finding them decayed to dead fish-heads when I finally can login next morning (or in the evening after work).
 
Last edited:

DeletedUser1264

This was a new issue, which has since been fixed, let me know if anyone else is still having issues
Now I'm having this problem on en2.
Cleared cache, cleared offline content, and the game still won't load.
 

chris Anjou

Farmer
Hello I have a problem in creating a message. I can no longer write the birth of a bbgm because example (bbgm temple at chris4973) how to go about writing the message only for my guild. Thank you for your reply.

cordially
 

ncshsg

Viceroy
Hello I have a problem in creating a message. I can no longer write the birth of a bbgm because example (bbgm temple at chris4973) how to go about writing the message only for my guild. Thank you for your reply.

cordially
Please don't reply on very old threads. Contact support so that this can be dealt with via the proper channels.